Dance Pad under Mac OS Catalina

Hey arrow friends,

I updated my Mac to Catalina. Now I installed Stepmania 5.3.0 and tried to configure my dance pad. Unfortunately, the Programm doesn’t seem to recognize my pad.

Under the Catalina System Information -> USB I found this entry, so the Mac seems to recognize it:
XBOX DDR
Product ID: 0x8888
Vendor ID: 0x1430 (RedOctane)
Version: 3.13
Speed: Up to 12 Mb/s
Manufacturer: Redoctane
Location ID: 0x14110000 / 19
Current Available (mA): 500
Current Required (mA): 100
Extra Operating Current (mA): 0

Any idea what I could do to use it with Stepmania again?

Thanks and have a great weekend,

Simon

I’ve tried the controller mapping as well, but that didn’t work. When I mapped the left arrow, it said “Joy1 B15”, but when I added the right arrow, it said “Joy1 B15”, too, and removed it from left.

The gemapad tool helped me to create a working manualmapping.txt and I was able to map the arrows, start and select. So far it’s working great!

my manualmapping.txt:
03000000301400008888000013030000,XBOX DDR,platform:Mac OS X,back:b6,start:b7,dpup:b2,dpdown:b1,dpleft:b0,dpright:b3,-righty:b9,+righty:b8,

Greetings,

Simon

Awesome, we can add this entry to the db so it will help other people in the future.