Help needed with dance pad on macOS Ventura

I’ve just installed OutFox (Mac Public Alpha on a MacBook Pro with macOS Ventura. Also, I bought a cheap dance mat on amazon (

When attaching the dance mat to my USB dock, it appears in macOS. However, when detaching it and re-attaching it, another copy of the device appears (this seems to be a macOS bug). That’s annoying but more importantly, I cannot use the dance mat in OutFox. Not a single button press is detected (it is also not shown in other tools that use USB game controllers).

On the same mac, I can run the Windows version of OutFox inside vmWare and there, I can easily configure the dance mat and use it. Unfortunately, OutFox in vmWare is dead slow.

I’m seeking advice in how to get the mat working on macOS. Any ideas here?

Try the latest release (LTS and see if the issue persists in there. If that’s the case, please send your game logs and also which usb dock/hub you’re using.

1 Like

Thanks. Unfortunately, I pasted the version number that Finder reports on the application bundle and for the LTS installer, this is actually “Mac Public Alpha” (broken tooling there?).

So, my report given above is for the latest release.

I’m using an elgato Thunderbolt 3 Dock. Unfortunately, I couldn’t find any logs. Following this documentation: I searched for a portable.ini file (none exists on my mac) and there is also no ~/Library/Logs/OutFox directory. Anything I can do to enable logging?

Anyone who can help here?

I’ve filed a bug report with Apple using Feedback Assistant (FB11988819) but no resolution so far. In System Profiler, the dancemat is reported as follows:

USB Gamepad :

Produkt-ID: 0x0011
Hersteller-ID: 0x0079
Version: 1.06
Geschwindigkeit: Bis zu 1,5 MBit/s
Standort-ID: 0x14100000 / 10
Verfügbare Stromstärke (mA): 500
Erforderliche Stromstärke (mA): 100
Zusätzlicher Betriebsstrom (mA): 0

Oh, and I’ve got more info now. Following, I downloaded the SDL2 Gamepad Tool and it does in fact see the dance mat and its button presses. It recognised the device as “Retrolink SNES” controller.

But what I can I do with that information? I’ve copied the Mapping String and added it to Data/gamecontrollerdb.txt, but that doesn’t change anything. I even tried to remove all lines but this mapping from the file. Still nothing.

What am I supposed to do after changing the gamecontrollerdb and starting Outfox to activate this one? I see that Outfox always sees a “Gamepad (Joy1)” but still cannot map any buttons as none are seen by Outfox (in contrast to the SDL2 Gamepad Tool).

First of all, sorry for the late reply. Hey there, do you mind joining the Discord server so devs can better directly assist you?

The solution is to use a USB 2.0 hub.

It forces Mac to use the kernel mode honour 2.0 according to Squirrel on the discord channel.

It worked for me!