PacDrive / USB Key issues on Ubuntu

Hey Crew,

Working on upgrading my custom built ITG 3 Cabinet, and was directed to OutFox as the best option right now. =D (Was formally on OpenITG b4 from way back when.)

Issue 1: I’m not able to get USB Keys to work.
I’ve followed all the steps here
github .com/stepmania/stepmania/wiki/Creating-Static-Mount-Points-For-USB-Profiles-%28Linux%29

Including trying /mnt/player1 as well as mentioned /mount/player1, etc.

My preferences.ini file contains this: (as per the guide)
MemoryCardOsMountPointP1=/media/player1
MemoryCardOsMountPointP2=/media/player2
MemoryCardPadmissEnabled=0
MemoryCardProfileImportSubdirs=
MemoryCardProfileSubdir=StepMania 5.3
MemoryCardProfiles=1
MemoryCardUsbBusP1=-1
MemoryCardUsbBusP2=-1
MemoryCardUsbLevelP1=-1
MemoryCardUsbLevelP2=-1
MemoryCardUsbPortP1=-1
MemoryCardUsbPortP2=-1
MemoryCards=1

My logs are showing this:

00:09.282: Starting thread: Worker thread (MemoryCardWorker)
00:09.283: Change in USB storage devices detected.
00:09.283: GetUSBStorageDevices
00:09.283: executing 'udevadm settle'
00:09.292: RageSound: Load "/Appearance/Themes/_fallback/Sounds/MemoryCardManager ready.ogg" (precache: 1)
00:09.300: RageSound: Load "/Appearance/Themes/_fallback/Sounds/_missing.ogg" (precache: 1)
00:09.313: RageSound: Load "/Appearance/Themes/_fallback/Sounds/_missing.ogg" (precache: 1)
00:09.314: RageSound: Load "/Appearance/Themes/_fallback/Sounds/MemoryCardManager disconnect.ogg" (precache: 1)
00:09.319: done executing 'udevadm settle'
00:09.319: OK
00:09.319: executing 'udevadm settle'
00:09.320: Starting thread: Worker thread (/@mc1int/)
00:09.320: Starting thread: Worker thread (/@mc2int/)
00:09.325: Profile::LoadAllFromDir( /Save/MachineProfile/ )
00:09.326: Loading /Save/MachineProfile/Stats.xml
00:09.327: Done.
00:09.331: done executing 'udevadm settle'
00:09.331: error No such file or directory
00:09.336:     sDevice: /dev/disk/by-path/pci-0000:00:1d.7-usb-0:1.2:1.0-scsi-0:0:0:0-part1, iBus: -1, iLevel: -1, iPort: -1, id: 0000:0000, Vendor: '', Product: '', sSerial: "<none>", sOsMountDir: ->
00:09.336:     sDevice: /dev/sr0, iBus: -1, iLevel: -1, iPort: -1, id: 0000:0000, Vendor: '', Product: '', sSerial: "<none>", sOsMountDir: 
00:09.336: Ignoring /dev/sr0 (couldn't find in /etc/fstab)
00:09.336: Done with GetUSBStorageDevices
00:09.336: New device connected: /dev/disk/by-path/pci-0000:00:1d.7-usb-0:1.2:1.0-scsi-0:0:0:0-part1
00:09.336: New device entering CHECKING: /dev/disk/by-path/pci-0000:00:1d.7-usb-0:1.2:1.0-scsi-0:0:0:0-part1
00:09.436: GetUSBStorageDevices
00:09.437: executing 'udevadm settle'
00:09.464: UnlockManager::Load()
00:09.466: done executing 'udevadm settle'
00:09.466: OK
00:09.467: executing 'udevadm settle'
00:09.480: done executing 'udevadm settle'
00:09.480: error No such file or directory
00:09.480:     sDevice: /dev/disk/by-path/pci-0000:00:1d.7-usb-0:1.2:1.0-scsi-0:0:0:0-part1, iBus: -1, iLevel: -1, iPort: -1, id: 0000:0000, Vendor: '', Product: '', sSerial: "<none>", sOsMountDir: ->
00:09.480:     sDevice: /dev/sr0, iBus: -1, iLevel: -1, iPort: -1, id: 0000:0000, Vendor: '', Product: '', sSerial: "<none>", sOsMountDir: 
00:09.480: Ignoring /dev/sr0 (couldn't find in /etc/fstab)
00:09.480: Done with GetUSBStorageDevices
00:09.480: executing 'mount /dev/disk/by-path/pci-0000:00:1d.7-usb-0:1.2:1.0-scsi-0:0:0:0-part1'
00:09.569: done executing 'mount /dev/disk/by-path/pci-0000:00:1d.7-usb-0:1.2:1.0-scsi-0:0:0:0-part1'
/////////////////////////////////////////
00:09.569: WARNING: failed to execute 'mount /dev/disk/by-path/pci-0000:00:1d.7-usb-0:1.2:1.0-scsi-0:0:0:0-part1' with error 256
/////////////////////////////////////////

I have gone into org.gnome.desktop.media-handling and turned off automount and automount-open

The guide does mention about running Stepmania from the CLI to avoid the GUI from mounting the drive (which may be the problem, even though it’s turned off in the OS). However that shows about 3 lines, and nothing happens.

  1. PacDrive is not working.

I’ve found github. com/stepmania/stepmania/pull/1479
and also projectmoon. dance/releases/5.3-a4.9.5
which states it SHOULD have PacDrive support.

This is what I’m getting in my logs

00:00.774: Initializing lights drivers: Linux_PacDrive
00:00.774: Unknown lights driver: Linux_PacDrive

(and also tried and got the same issue with just “PacDrive”
I DID follow the steps in the guide about
apt-get install libusb-dev libusb-1.0.0 libusb-0.1-4
and also adding
sudo echo SUBSYSTEMS=="usb", ATTRS{idVendor}=="d209", ATTRS{idProduct}=="1500", SYMLINK+="pacdrive", OWNER="stepmania" > /etc/udev/rules.d/90-pacdrive.rules
(which gave me a permissions denied, even using Sudo. So I had to sudo su, then do it.)

  1. Bonus question: Previously in old SM and OpenITG, you could put a static.ini file to override the stepmania (or now) preferences.ini file, can you still do that?

  2. Bonus Question 2: Can you make the linux version “portable” so it’s not saving the logs and other such stuff into an invisible folder in the home folder? and saving it it’s own folder?

Thank you A LOT in advance. I’ve been away from my ITG 3 cabinet for many years (living in another city) and it’s nice to have it back… (Hopefully with lights and USB keys :wink:

Oh and while i’m here, Bonus Question 3… is there a compatible ITG3 theme for OutFox?

Cheers!
(and new users can only put 2 URLS in a post, so had to hax0r those up a bit.)

IF anyone actually does look at this. I got my issues solved (or well pointed in the right direction) on the Discord Channel.

  1. Use Ubuntu 18… not 20. 20 refuses to not auto mount things.

  2. Someone changed the code for the driver… it’s currently “LinuxPacDrive” not “Linux_PacDrive”
    However there are also issues with it requiring Sudo… (and there are some issues on 20 with that.) So again, go to Ubuntu 18.

  3. Yes. Static.ini is valid. Just put it into the Data folder, not the Game folder

  4. Yes. make a text file called “portable.ini” in the same directory as the Stepmania app.